"Error: failed to fetch an image or build from source: error building: provided file is not a console"

Anyone else running into this issue? I can’t deploy anymore.

Also an old commit that successfully deployed 7 hours ago now yields that same error.

I’ve also emailed support about this (including DEBUG deploy logs) but I am curious if there’s anyone else running into it and has found a fix.

Just ran into this myself. Maybe a temporary issue since nothing changed on my end.

1 Like

Are you by any chance using fideloper/fly-laravel? Which region are you in? Maybe there’s a pattern :slight_smile:

EDIT: Hm, I doubt region matters considering it already fails at the builder.

What I tried so far:

  • Destroyed the builder
  • Restart the deploy

Both didn’t work.

IAD region - deploying via GitHub Actions. It’s a Remix app.

1 Like

I am also hitting this same issue for the last 20+ minutes or so.

Not sure if that’s the cause of it, but I also deploy via github action

are you deploying via github actions?

Yes I am deploying via github actions

Yea it seems to work fine when running from CLI.

What seems to work is the following:

  • Either deploy locally completely.
  • But what I did: I ran fly deploy ---build-only locally and then triggered the github action again. This seems to work.

newest flyctl version locally (installed via homebrew) is 0.1.58 and the one used in the github action is 0.1.59 (which was released an hour ago)

maybe related.

Updating the github action to pin to the previous version worked.

      - uses: superfly/flyctl-actions/setup-flyctl@master
          version: 0.1.58

FYI We’ve revoked 0.1.59 and 0.1.60 while working on the fix for this issue.

No need to pin the version to 0.1.58 if you don’t want to.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.