error connecting to docker: could not create remote builder: EnsureRemoteBuilderInput isn't a defined input type (on $input)

I am trying to deploy an app, I’m getting this error with the fly.tomly generated by fly launch.

Getting the same sounding problem with fly deploy

==> Verifying app config
--> Verified app config
==> Building image
WARN Failed to start remote builder heartbeat: must provide either an organization id or app name
WARN failed to create build in graphql: input:3: createBuild Could not find App

Error failed to fetch an image or build from source: error connecting to docker: must provide either an organization id or app name

The full command I’m using is like this:

fly deploy --remote-only -c my-app.toml --app my-app-name --build-arg CUSTOM1=arg1 --build-arg CUSTOM2=arg2

This is from our usual deployment script which hasn’t change in a long time. I’m using the latest cli: flyctl v0.0.421 linux/amd64 Commit: b872b3fa BuildDate: 2022-10-26T22:14:45Z

This error usually means that the current authenticated user does not have access to the app being deployed. A quick check is running fly apps list using the same environment/auth, and verify that the app in my-app.toml shows up in the list.

Try running with LOG_LEVEL=debug and see if that gives any additional clues about what’s failing.

@terrcin the latest release has a bug, it’s getting looked at by at the moment, try using the previous version of the cli

1 Like

saved me writing up a complicated update. thanks.

how do I rollback the version?

@terrcin if you’re using homebrew you should be able to use brew install flyctl@0.0.420

Unfortunatly not via brew. I did figure out I could download the install script and then downgrade this way:

./ v0.0.420

Have a fresh deploy in progress.

being able to go fly version rollback would be handy :slight_smile:

1 Like

We yanked v0.0.421 so you don’t need to specify a version to get a working build. We can’t revert in Homebrew unfortunately because flyctl is in the core. You’ll need to either switch to the script install or wait for a fix tomorrow. Sorry about this!

1 Like

This was fixed in v0.0.422. Thanks for the report!

1 Like

It would be best to bump to v0.0.424 to get another related fix, for those relying on the --app flag to override an app name in fly.toml.

I am running on v0.0.431 and this is still going on.

Can you paste output of your command with LOG_LEVEL=debug set?