domain works through smartphone same network does not work on mac or pcs.

Hi, I don’t understand what is going on… I have been using fly for a while , the process to add custom domains always worked well.

But, not this time.

It’s well validated

I can reach my app through my iphone (same network) but I cannot reach the app through mac, or even a windows pc in another country does not work.

DNS propagation looks good here: dns checker.

I even switch the domain to another server I have on godaddy and it works well. So… Is there something more that I need to configure on fly? I have deleted and recreated the app twice same thing, problem is there. Internal fly domain is working well. I’m almost giving up.


Strange :thinking:

The only suggestion I have is making sure you have both A and AAAA records pointed to the right values (IPv4 and IPv6 respectively). Your screenshot only shows a reference to an AAAA record, so I wasn’t sure.

Only if you just have an AAAA (IPv6) record, and not an A (IPv4) record, that would mean only devices that support IPv6 could resolve the domain. New devices and networks will support IPv6 but older devices may not. They will default to IPv4, and try and lookup e.g And if they don’t get an A record back … they give up. And hence the site does not load. Devices that either support IPv6 as primary or are happy falling back to it would work. Fly’s name.internal domains use IPv6, as does the private network, so again that would suggest it’s related to that.

Hi @greg! You are right, I tried a couple hours ago I was planning to write here. it’s working now. Thanks a lot for taking the time to answer my question.

I’m wondering why the instructions on fly don’t say that? That we must add an A record. maybe it’s too obvious but it wasn’t for me.

1 Like