Deploy Failed "machine did not have a private IP"

Working on a new app and have been deploying all day. Haven’t touched my default configuration.

Seeing this error:

WARN Failed to start remote builder heartbeat: machine did not have a private IP
Waiting for remote builder fly-builder-lingering-lake-5181… :earth_americas:Error: failed to fetch an image or build from source: error connecting to docker: machine did not have a private IP

Anything going on on your end? Any advice if this is something I can fix? Like I said, I was deploying earlier today without a problem

Another thing to mention is that the builder is attempting to pull from the registry without success. (the name in the screenshot is different than the logs posted above, I deleted the builder app and created a new one after going through another “flyctl launch”)

Another thing I tried was deleting my shared builders (again), creating a new app in a different region and running flyctl launch. My thinking was since the builder in the ord region for whatever reason can’t pull from the registry, then maybe another region will work. So I created a new fly.toml:

app = “rough-mountain-8973”
primary_region = “bos”

internal_port = 80
force_https = true
auto_stop_machines = true
auto_start_machines = true
min_machines_running = 0

But I’m still seeing ord in the new builder logs. Is this right?

Same problem here. Deployed an app a few months back and have pushed to it a few times. I just tried restarting and same deal. Seems like a bug on @fly ?

Really would hope there’s a response from the team here since there’s no useful logs to help debug this one.

@zricethezav Deleting a remote builder is indeed always worth a try. The problem is the next builder won’t be created in the region of the app, but closer to you. Or at least that was how it used to work.

If it is just an issue with the remote builder (e.g its networking) and you happen to have Docker installed/running locally, you could try switching to a local build with fly deploy --local-only. Again, always worth one try until the issue is resolved.

Trying the same thing now and looks like it is fixed. Not sure why at all, just happy it is working.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.