Upgraded from Hobby to Launch and I can't deploy anymore

I upgraded from a Hobby account to the Launch plan and I can’t deploy anymore.
Is the runner changed when doing this?

==> Verifying app config

--> Verified app config

==> Building image

WARN Remote builder did not start in time. Check remote builder logs with `flyctl logs -a fly-builder-<my-builder-123>`

WARN Failed to start remote builder heartbeat: remote builder app unavailable
Waiting for remote builder fly-builder-<my-builder-123>... 🌏

...

Error failed to fetch an image or build from source: error connecting to docker: remote builder app unavailable

The logs of the runner says

2022-10-27T07:00:45Z runner[123456789] fra [info]machine exited with exit code 0, not restarting

It’s been in this state for at least 4 hours…

Updating plan types doesn’t change anything about your builder, no.

Have you tried destroying your current builder app? This can be a good initial troubleshooting step/workaround for an unreachable builder

I tried restarting it, but destroying it seems a bit of an overreach?

Will this not simply remove the builder app from my account leaving me with no way to deploy anything?

It looks like my builder app has been deleted somehow. Maybe automatically since it didn’t respond?

Adding an “abstraction” around the deploying would help us who are new to working with docker (and kubernetes or whatever you use in the background) uncofortable.

Something like “fly builder recreate” that destroys the builder and recreates a new one seemlessly.

Fortunately a new one is created if none is present.

1 Like