Certificates labeled as verified but can't access my api (This site can't be reached), tried with 4 domains


I’m adding the domain name through the web UI and then filing the AAAA record on my DNS provider, it’s labeled as verified on your end but I can’t access my API.

I’ve tried with 4 different domain names, 2 on Cloudflare (DNS only not proxied by them) and 2 on NameCheap basic DNS and same output, I don’t have any specific error message, just the standard “This site can’t be reached” on Chromium and “Unable to connect” on Firefox.

I really doubt it’s a problem with some allowed hostnames in my code since the “project.fly.dev” serves the app flawlessly although not mentioned anywhere in my config.

Also all flags are red on MXToolbox.

I’ve had the same problem 10 days ago FYI and just retried today with the same output.

app name : pollosapi

Would you know how to fix that ? Thanks in advance.

This sounds like you don’t have IPv6 internet access on your machine.
Your app has an IPv4 address, but your custom domain doesn’t have an A record. If you want your domain to be accessible via IPv4, you’ll need to also set an A record on your DNS provider.

My bad I’ve done it multiple times but missed it here, it’s working now, but why when adding the domain name through the UI only “Confirm domain ownership optional” + “CNAME” and “Direct visitors to application” + “AAAA” are mentioned and not the A record + IPV4 ?

Thanks !

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.