Can't update Postgresql machine "Error: no config changes found"

I have a postgres app running with 256MB and I wanted to update the memory.

I run
fly machine update -a comreport-db-staging

and get:
Error: no config changes found

I run
fly scale memory 1024 -a comreport-db-staging

and get:

Error: No active machines in process group 'app', check fly status output

When I run
fly status -a comreport-db-staging

I get

ID            	STATE  	ROLE   	REGION	CHECKS            	IMAGE                             	CREATED             	UPDATED              
4d89646f433328	started	primary	lhr   	3 total, 3 passing	flyio/postgres-flex:15.3 (v0.0.46)	2023-12-12T13:52:17Z	2023-12-12T13:52:28Z	
48ed674c395418	started	replica	lhr   	3 total, 3 passing	flyio/postgres-flex:15.3 (v0.0.46)	2023-12-14T12:31:34Z	2023-12-14T12:33:33Z	

I ran machine clone thinking I can solve it but created a replica which I can’t update either.
I also need to delete the replica but even after stopping and destroying I can’t get it to be removed!


hi @cymkd

Postgres apps are a bit different than regular appa. You can scale up individual Machines with:

fly machine update <machine id> --vm-memory <memory in MB> -a <app name>

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.