can't setup ssh

I am trying to copy my pb_data folder to my local machine, but can’t seem to setup ssh.
I’m trying to follow the steps listed here: Host for free on Fly.io · Discussion #537 · pocketbase/pocketbase · GitHub

My problem is that when I flyctl ssh issue --agent I get Error slug argument must be specified when not running interactively

When proceeding with the proxy and scp anyway I get Permission denied (publickey)

It would be helpful to know what operating system you are using.

I’ve seen similar errors reported on windows, and to date I can’t reproduce the error with either Command Prompt or Powershell, using either Windows Console Host or Windows Terminal.

Perhaps try the terminal in VS Code? See When I run fly launch to my project I get the following error: Error name argument or flag must be specified when not running interactively - #9 by lovelidevs

I’m running Windows 10 Pro 21H2.

I tried with powershell through VSCode but the problem persists.
I also made sure ssh-agent is running via

Get-Service -Name ssh-agent

status is running

I found the following method which allows for transfer of single files at a time:

From the local directory containing the fly.toml file:

fly ssh sftp shell

This will start an interactive session where you can navigate, push and pull files within the remote machine.

get FILENAME

will download a file into your current directory.
It would be nice to have a recursive option to download a folder with all its files more easily though…

To replace a file, if the PUT command does not overwrite, you can first fly ssh console, then rm FILENAME to remove the file. Then add the new file via fly ssh sftp shell again.

1 Like