Cannot start APP because of insufficient CPUs


I am working on a http app. And I setting all the auto-start-machine and auto-stop-machine enable.

Since Aug.4, I found my app cannot start automaticly. At the restart and re-deploy step, it fails with this logging:

could not stop machine 9185727eb19018: 
failed to restart VM 9185727eb19018: 
unknown: could not reserve resource for machine: 
insufficient CPUs available to fulfill request

I follow the docs and try to re-deploy it. It’s taken me almost ten hours, but I still don’t have a clue. :rofl:

I also tried clone the machine , but it seems to just create the volume.

The region where my app is located is Tokyo and the machine ID is VM 9185727eb19018

Has anyone else had the same problem? If anyone can give me some ideas on how to solve the problem, I’d appreciate it!

Excited to announce that the problem is solved. Took about 12 hours to fix.

Note that the following methods may lead to irreversible consequences, so please take responsibility for them yourself

  1. find backup of the volume: fly volumes snapshots list vol_xxxxxxxxxxxxx

  2. destroy the current machine: fly machine destroy xxxxxxxxxxxx

  3. Delete the [mount] configuration in fly.toml

  4. Re-deploy: fly deploy

  5. Create the volume from the backup: fly volumes create data --snapshot-id vs_xxxxxxxxxxxxxxx -s 1

  6. Clone the new machine created in step 4 and attach the volume created in step 5: `fly machine clone xxxxxxxxxxxxxx --attach-volume vol_xxxxxxxxxxxxxxx:/data/xxxxxxxxxx’

And that’s it!

I’m glad my blog is resurrected :yum:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.