Cannot deploy app

When I run flyctl deploy it hangs after this output:

Waiting for remote builder fly-builder-wandering-butterfly-1197... 🌏 

fly.toml:

# fly.toml file generated for sudobot on 2022-09-09T21:38:41+06:00

app = "sudobot"
kill_signal = "SIGINT"
kill_timeout = 5
processes = []

[mounts]
  source="data"
  destination="/data"

[env]

[experimental]
  allowed_public_ports = [4000, 80, 443]
  auto_rollback = true

[[services]]
  http_checks = []
  internal_port = 4000
  processes = ["app"]
  protocol = "tcp"
  script_checks = []
  [services.concurrency]
    hard_limit = 25
    soft_limit = 20
    type = "connections"

  [[services.ports]]
    force_https = true
    handlers = ["http"]
    port = 80

  [[services.ports]]
    handlers = ["tls", "http"]
    port = 443

  [[services.tcp_checks]]
    grace_period = "1s"
    interval = "15s"
    restart_limit = 0
    timeout = "2s"

If I run flyctl logs -a fly-builder-wandering-butterfly-1197 it shows:

2022-09-29T14:09:38Z runner[591857d7f37083] sin [info]machine exited with exit code 0, not restarting

How do I fix this?

Hi!

Can you please try this out (in this order!)

  1. Try to deploy again with debug on. LOG_LEVEL=debug fly deploy
    • Let us know if you spot errors there (perhaps pertaining to wireguard, but maybe just a timeout in waiting for the builder to become available)
  2. Assuming you still get an error after trying number 1 above, try destroying your builder app and then deploying again. Fly will create a new builder app and attempt to deploy with it.