cannot deploy an app despite billing information being set

I have added billing information to my new org, but I cannot deploy with the following error. What is the fix for this?

$ flyctl deploy
==> Verifying app config
Validating /Users/{user}/projects/{name}/website/fly.toml
✓ Configuration is valid
--> Verified app config
==> Building image
WARN Failed to start remote builder heartbeat: We require your billing information, please add it at{orgname}/billing

Error: failed to fetch an image or build from source: error connecting to docker: We require your billing information, please add it at{orgname}/billing

I had to manually pay my first invoice despite adding the billing details during my account setup process. This resulted in the error going away, and being able to successfully deploy.

Bah that’s annoying. Thank you for bringing this to the forum.

We are starting to roll out some billing changes in newer organizations and it seems we missed part of making this work well for folks. Sorry about that.

We’ve rolled out some changes to make this work more smoothly going forward.

Hi @jphenow, if I understand correctly, should this be fixed now?

I’m running into the same issue. I’ve added payment details for the previously-unused organisation, and even tried buying some credit. The credit shows, but I still get this error when I try to deploy.


Hi, @jphenow, I still get this error after creating a new organization and adding my billing information.

1 Like

Hey @man8 and @cozybytes can you email in to so we can take a closer look?

Thank you - resolved for me.

Hi @jphenow I’m seeing this issue and sent a email to

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.