Cannot access console anymore

Since some days (more then a week) I cannot access the fly ssh console anymore. Note quire sure why, thought. Deploying works just fine. Just the ssh console stopped working.

flyctl doctor says the following:

Testing authentication token... PASSED
Testing flyctl agent... PASSED
Testing local Docker instance... PASSED
Pinging WireGuard gateway (give us a sec)... FAILED
(Error: ping gateway: no response from gateway received)

We can't establish connectivity with WireGuard for your personal organization.

WireGuard runs on 51820/udp, which your local network may block.

If this is the first time you've ever used 'flyctl' on this machine, you
can try running 'flyctl doctor' again.

If I am seeing this status issue right, there was some UDP related outage, but it’s said to been resolved since 5 days. So no idea, if that is related or what else the problem can be.

Anything else I can try? Anyone an idea how I can resolve this?

I’m not aware of any widespread issue that could be causing this, but it worked before; I’ll do my best to help unbreak it!

I checked really quickly to rule out it being just now broken everywhere-- what region are your instances in?

If nothing has changed on your end, configuration-wise, the following steps might help us find a good place to start investigating:

  • you can try connecting over TCP, instead, with fly wireguard websockets enable
  • you can try changing out wireguard peers with fly wireguard reset, fly wireguard remove, and fly wireguard create

For additional context on the above flyctl commands, the troubleshooting in this thread might help too:

If you’re stuck please feel free to let us know! It would help us check on our end if we knew whether this is app-specific, and if so, what the output of fly status is for it.

I am (or my nodes are) in fra.

Now the fly ssh console finally can connnect, after I did fly wireguard websockets enable and fly wireguard reset. Did them both at once, before I tried checking, not quite sure what did the trick. I have also no clue what those tasks are doing, but am glad that I can connect to my iex console. :slight_smile:

Awesome, thank you for letting us know!

For context, fly wireguard websockets enable can help rule out any issues with your local network, since if you can’t establish any connections to port 443 from your local network, you’d certainly notice other problems, like https not working

fly wireguard reset is more of a “percussive maintenance” type of troubleshooting as far as I understand it-- by creating a new peer you can sidestep anything that may have gone sideways with the old one.

There are definitely other people in the community who might explain it better, and our 6PN and user-mode wireguard articles might help shore up anything I got wrong or missed with my answer here.

Glad to see that things are working again-- feel free to respond with any other questions :slight_smile: !