Can no longer deploy - Docker internal build context error

Hi all,

I have seen a similar error in other threads over the last month or two, but none of the resolutions worked for me.

Background - Elixir application, developed on Mac with Apple silicon.

Successfully deployed regularly until today - the last successful deploy was 24hours ago.

However, today I can no longer deploy using fly deploy, I don’t know what’s changed - there was no indication of any flyctl autoupdates between yesterday and today. The only change in the project was about 10 lines of javascript.

I now get the following error:

 => [internal] load build definition from Dockerfile                                                                                    0.5s
 => => transferring dockerfile: 32B                                                                                                     0.5s
 => [internal] load .dockerignore                                                                                                       0.4s
 => => transferring context: 35B                                                                                                        0.4s
 => [internal] load metadata for                                                        1.4s
 => [internal] load metadata for                                1.3s
 => [stage-1 1/6] FROM  0.0s
 => [builder  1/22] FROM  0.0s
 => ERROR [internal] load build context                                                                                                42.7s
 => => transferring context: 6.66MB                                                                                                    42.7s
 => CACHED [stage-1 2/6] RUN apt-get update -y && apt-get install -y libstdc++6 openssl libncurses5 locales git   && apt-get clean &&   0.0s
 => CACHED [stage-1 3/6] RUN sed -i '/en_US.UTF-8/s/^# //g' /etc/locale.gen && locale-gen                                               0.0s
 => CACHED [stage-1 4/6] WORKDIR /app                                                                                                   0.0s
 => CACHED [stage-1 5/6] RUN chown nobody /app                                                                                          0.0s
 => CACHED [builder  2/22] RUN apt-get update -y && apt-get install -y build-essential git npm curl   && apt-get clean && rm -f /var/l  0.0s
 => CACHED [builder  3/22] WORKDIR /app                                                                                                 0.0s
 => CACHED [builder  4/22] RUN mix local.hex --force &&   mix local.rebar --force                                                       0.0s
 => CACHED [builder  5/22] RUN curl --proto '=https' --tlsv1.2 -sSf | sh -s -- --default-toolchain stable --profi  0.0s
 => CACHED [builder  6/22] RUN echo $(rustc --version)                                                                                  0.0s
 > [internal] load build context:
Error: failed to fetch an image or build from source: error building: failed to solve: rpc error: code = Canceled desc = grpc: the client connection is closing

What I have tried to resolve the issue:
0. Check Fly status page for outages. None evident.

  1. Deleting the builder app to force creation of a new one. No difference.
  2. Downgrading flyctl as per previous threads (0.1.58 seems to be a popular choice) - doesn’t work because it immediately auto-upgrades to current version.
  3. Restarting wireguard and agent. No difference.
  4. Trying --remote-local option on fly deploy. Doesn’t work for me because erlang in docker image version segfaults on Apple silicon.

Any help getting deploying again would be much appreciated!

Update: I have a workaround :grinning:

So I went through the pain of turning on a windows laptop and letting it go through the two update / reboot cycles and dismissing the incessant “upgrade to Windows 11” nag screens you have to go through every time you leave it off for a couple of months. It looks like it deploys ok from there (without using the --local-only flag), so the issue appears to be with the Mac version of fly deploy.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.