App not getting deployed

Hi, getting the below error when trying to deploy an app

There’s no mention of it in docs. Would appreciate some help.
If it helps, one of the previous deployment was disconnected in between and this error started coming up after that. Could it be related to that?

Can you try again? This is likely related to our outage this morning.

My CI is failing to deploy as well; retrying every now and then - will post here once it goes green.

Edit: about one hour later - still having issues (stuck with “Monitoring Deployment”).

Stuck at “Monitoring Deployment” could be something else. I did see your builder come up and stay up for about 12 minutes? This would mean it built something and then exited (hopefully, successfully).

Yeah, it builds fine and the release_command seems to run too. After that it just stays with Monitoring. The only change between my previous deployment was updating a dependency (node types, patch level). Will try an earlier revision and see…

I just reverted to the same commit sha that is deployed already (known working) - this time it seems to have gotten stuck in release_command (Running release task (complete)...⣻) .

Also getting the same error of * No deployment available to monitor but the app is successfully deployed.

My apps are open source, so here’s the CI link:

I have the same issue (No deployment available to monitor).

The deployment appeared to succeed but my app was deployed to a backup region (ams) rather than the desired region (lhr).

Sorry to say but this is still an ongoing issue for me

@jbergstroem What are you seeing exactly?

We’re trying to find scenarios where it’s still broken.

Just tried again. I’m actually greeted by an error now:

Error error creating nats connection: could not connect to nats: read unix ->/Users/jbergstroem/.fly/fly-agent.sock: i/o timeout

…and retrying straight after leads me to a spinner at:

Running release task (complete)…⣻

(as others have mentioned, it seems to deploy correctly)

Can you try fly agent restart. It might help, but this is odd. What version of flyctl are you running? (flyctl version)

I’m at .246 - just updated to .247


flyctl status tells me the deployment went fine:

5c0a2d5f app     83 ⇡    scl    run     running 1 total, 1 passing 0        35s ago
d0fb0d06 app     82      scl    stop    running 1 total, 1 passing 0        19m13s ago

OK, deploys seem to be working for me once more, but as previously mentioned an earlier deploy deployed to a backup region (ams) rather than the desired region lhr.

I did a new deploy but it’s still deployed to ams. I also tried scaling my replica count up and back down again. The new replica was deployed to lhr but when I scaled back down it was the lhr replica that was deleted.

Any ideas how I can get my app deployed to the right region?

Just wanted to “close” the thread properly from my end - things are back to normal since around 5h ago.

1 Like