App not accessible when volume is mounted

I’m building a rails app that I am wanting to enable a volume on. Without the volume the website is accessible, however when I add:


to my fly.toml, the deploy still works however the site isn’t accessible (502 error after a while of waiting).

If I log into it with “fly ssh console” I can see the volume at the correct place. If I run “fly logs” I can see puma running, however no requests reach it.

“fly volumes list” shows the name being data, in the correct region. It is also assigned to the correct app.

Any idea what’s wrong?

As near as I can tell you are doing everything right, and looking at all the right places.

At this point, all I can offer you is an application that does pretty much what you are describing and you should be able to get it up and running in minutes. Try: Litefs · Fly Docs , but feel free to omit --litefs --region iad lhr and fly scale count 2.

I just reran those instructions (omitting litefs, etc), and they worked for me. Hopefully they work for you and you can spot some difference between this minimal demo application and your application.

I just checked the website again and now its randomly working. I guess it was issue.