After two months, postgres database suddenly stopped working, citing "getadrinfo ENOTFOUND top2.db-app-name.internal". Any tips?

Basically just the title. My app is unable to connect, and cites the issue in the title. The db monitoring just has the lines " no keeper info available " and nothing else, and says the app is deployed.

I also can’t access the db with the flyctl proxy command.

Any tips on where to start troubleshooting?

Same thing happened to me, restarting the db with fly pg restart -a (db app name) fixed it so I guess the database was just frozen or something

“No keeper info” available means postgres crashed, most likely due to an out of memory error. The restart is the right choice when this happens. Someday we’ll have good notifications so you’ll know exactly when this happens, it’s a bit hard to detect right now.

Thanks for the tips, I’ll restart. Just to confirm, will this clear all my data?

When I run this command, I get" “Error no active leader found”

That could mean it’s out of disk space. fly checks list -a <pg-name> will show you more information.

That output gave me:

Looking at the web interface, I have only used 9.5MB of a total of 1GB

I followed the advice in Database unavailable. Can't connect nor restart or anything else. - #3 by Sam-Fly, and it worked without clearing data:

List machines for your Postgres app
fly machine list -a <name>

Restart machine
fly machine restart <machine-id> <name>

1 Like