422: Not allowed to create machines

Hi guys, when I deploy a machine with the following command, I get a 422 error: (I tried to create the machine using the APIs and still got the same)

fly machines run nginx -a <app_name>
# Error could not launch machine: failed to launch VM: 
#  You are not allowed to create machines

I am using the Launch plan and have tried the following but it still doesn’t work:

  • Increase and decrease the memory and CPU of the app
  • Change the name to something different

Does this seem to have some kind of limitation? Or should I go somewhere and submit a form to request this feature?

As you might know, the launch plan comes with free email support! Since this error involves account-specific info, I’ll reach out to you there in a few minutes :slightly_smiling_face: !


i got the same issue when cloning PG to another location.
The volume gets created, but not the vm.

Any solutions?

The cause of the issue I was having was triggering the risk control, and it was the Fly staff that ended up helping me out. Maybe you can consult some of the staff by email.


Hey @witt-dev - thanks for letting me know!