VPN is required in most wifi networks


We are using fly vpn as a server for connecting our users to their database files.
Till now everything has been going very well For a couple of weeks we have issue with the VPN requirement.

Without a VPN running on a local computer, our user cannot connect to the fly server.

But on mobile data network, they can connect.

I have talk to wifi providers they are saying they didn’t blocked any servers. how we can solve this issue?

I think you definitely have to provide more information to fix the problem.
For example, what kind of error was encountered, network route information, etc.

Also, what do you mean by “database files” here? What part of your system is Fly.io in?

The following issue is happening because when no vpn is connected, after connecting vpn this issue is solved.

What is the output of the LFT command?

sudo lft -N api.fly.io

If not installed:

brew install lft

When I run: fly status

I get the following error:
Error: failed to list active VMs: failed to list VMs: Get "https://api.machines.dev/v1/apps/amanimsp/machines": EOF

When running sudo lft -N api.fly.io

I get the following error:

Tracing ............*.*T
TTL LFT trace to
 1  [NULL] 5.3ms
 2  [NULL] 56.1ms
 3  [NT-2] 39.1ms
 4  [Etisalat] 180.9ms
 5  [ETISALATAFG-AF] 163.8ms
 6  [NULL] 136.1ms
 7  [NULL] 116.8ms
 8  [ETISALATAFG-AF] 89.1ms
 9  [NULL] 38.2ms
10  [TWA] 106.3ms
11  [NULL] 98.5ms
12  [NULL] 90.5ms
**  [neglected] no reply packets received from TTLs 13 through 14
15  [US-FLY-20181213] [target open] 164.0ms

If your Fly app only has an IPv6 address, but your Internet provider doesn’t support IPv6, you might see this issue. You can check whether your ISP is giving you an IPv6 address here - https://ipv6-test.com/

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.