volume maintenance

Hi, this issue might be similar to this one: volume attached to destroyed machine

But I had the following situation:

  • machine immediately shuts down due to bad config in volume
  • can’t SSH into the machine (due to it rebooting immediately)
  • I know what is wrong in the config

I was hoping to be able to do something like specifying --entrypoint for a docker image. I tried things like the following:

  • fly m run -a forgejo-instance --volume forgejo:/data .
    but all I got in return was

Error: No unattached volumes in region ‘ams’

this made me think that the app had a machine running, so i did do fly m stop as well, but I suspect it instantly tried to restart a machine :thinking: attaching the volume as well.

This is all sadly in the past tense since I ended up with the idea that destroying an app would for some reason not destroy the app’s volume. It’s gone now, granted nothing important was on it, but I wanted to learn how to do some maintenance for the future. Is there any newbie guide on how to do some maintenance on volumes? I wanted to be able to do any of these:

  • specify an entrypoint for the docker image/container. I tried the --shell flag for the fly machine run, but maybe there’s something similar that could start a machine but set the docker --entrypoint to a bash shell? (preferred solution), this would prevent the machine from running whatever the normal entrypoint was that would cause it to crash instantly.
  • attach a volume to a different machine that i can use to fix some config inside it. It kept telling me it was attached already… so I didn’t succeed with this.

I kinda hope to be able to recreate this issue in the future, and if I do, i’ll post here if I find a working solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.