Unable to run flyctl ssh establish

Hi there,

I’m trying to follow this guide (IEx into Your Running App · Fly Docs) to ssh into my app, however running flyctl ssh establish just shows the help menu and doesn’t do anything. Anyone have an idea of how to run flyctl ssh establish?

Take a look at the Docs

Try flyctl ssh console -c fly.toml

Gotcha - I’m able to ssh with that but I’m unable to run rails commands there.

If I try running: fly ssh console -C "app/bin/rails c"
I get the error: fork/exec app/bin/rails: no such file or directory

From the command output you posted, seems like it connected!

you’re trying to run app/bin/rails in the current dir.

Try fly ssh console -C "/app/bin/rails c" and let me know how that goes?

I can’t run that command :frowning: It gives me this error.

Hi @aspa,

Could you try the following command?

$ fly ssh console -a app_name -C "app/bin/rails c"

Hope that helps,
Sergio Turpín

Take a look at this

fly ssh console -C “/app/bin/rails console”

Let me know

fly ssh console -a app_name -C "app/bin/rails c"
This gives me the same error as before.


Looks like the chmod is for permissions errors, I’m getting file not found errors.

Using fly ssh console -C "chmod +x /app/bin/rails" gives me the same error as well:
fork/exec app/bin/rails: no such file or directory

When I ssh into my console I don’t see any Rails folders/files, do I need to change the fly.toml setup? I currently have this under build:

  image = "flyio/hellofly:latest"
    BUNDLER_VERSION = "2.2.12"
    NODE_VERSION = "16.15.1" 
    RUBY_VERSION = "3.0.0"```

Hi @aspa!!

If you don’t have any files, the docker image is probably not mounted correctly. In order to evaluate your issue, a couple of questions come to mind:

Was your app working properly?
When did everything stop working?

Sergio Turpín