Unable to make deploy


$ flyctl deploy


Waiting for remote builder fly-builder-snowy-lake-6066...

And no progress at all.

How I can deploy new changes to fly.io ?

You could try destroying your builder with fly apps destroy fly-builder-snowy-lake-6066 (I think that’s the syntax?). It will recreate it. It’s worth a shot…

Did as you said.
Now I have a new deployed builder and the same problem, unfortunately :neutral_face:

Then the only option is to wait for a Fly.io dev that can fix it :slight_smile:

Oh I just thought of this: you can also build locally if you have Docker installed. fly deploy --local-only should do it.


flyctl deploy --local-only solved my problem.

Thank You!

Yes – if building locally isn’t an option you can generally get more information about hangs by running LOG_LEVEL=debug fly deploy which can help pinpoint the problem.

1 Like

Hi, I tried to deploy using github actions but I get this error:

Waiting for remote builder fly-builder-black-frog-9771...
Error failed to fetch an image or build from source: error connecting to docker: remote builder app unavailable
WARN Remote builder did not start in time. Check remote builder logs with `flyctl logs -a fly-builder-black-frog-9771`

I tried destroying the builder but it doesn’t work. Here is my gh workflow:

name: Fly Deploy
on: [push, workflow_dispatch]
  FLY_API_TOKEN: ${{ secrets.FLY_API_TOKEN }}
      name: Deploy web app
      environment: staging
      runs-on: ubuntu-latest
        - uses: actions/checkout@v2
        - uses: superfly/flyctl-actions/setup-flyctl@master
        - run: flyctl deploy --remote-only

For some reason I can deploy without any issue from local.