Unable to deploy React app docker image

Hi,
I can’t deploy my React App with a Docker image.
fly log:

2022-08-27T13:55:34.967 runner[8499e70e] cdg [info] Starting instance

2022-08-27T13:55:35.124 runner[8499e70e] cdg [info] Configuring virtual machine

2022-08-27T13:55:35.128 runner[8499e70e] cdg [info] Pulling container image

2022-08-27T13:55:35.581 runner[8499e70e] cdg [info] Unpacking image

2022-08-27T13:55:35.597 runner[8499e70e] cdg [info] Preparing kernel init

2022-08-27T13:55:35.970 runner[8499e70e] cdg [info] Configuring firecracker

2022-08-27T13:55:36.058 runner[8499e70e] cdg [info] Starting virtual machine

2022-08-27T13:55:36.235 app[8499e70e] cdg [info] Starting init (commit: f815f49)...

2022-08-27T13:55:36.258 app[8499e70e] cdg [info] Preparing to run: `docker-entrypoint.sh npm start` as root

2022-08-27T13:55:36.282 app[8499e70e] cdg [info] 2022/08/27 13:55:36 listening on [fdaa:0:8a5e:a7b:ae02:8499:e70e:2]:22 (DNS: [fdaa::3]:53)

2022-08-27T13:55:37.027 app[8499e70e] cdg [info] > rotondo-website@0.1.0 start

2022-08-27T13:55:37.027 app[8499e70e] cdg [info] > react-scripts start

2022-08-27T13:55:40.851 app[8499e70e] cdg [info] ℹ 「wds」: Project is running at http://172.19.5.98/

2022-08-27T13:55:40.852 app[8499e70e] cdg [info] ℹ 「wds」: webpack output is served from

2022-08-27T13:55:40.852 app[8499e70e] cdg [info] ℹ 「wds」: Content not from webpack is served from /app/public

2022-08-27T13:55:40.852 app[8499e70e] cdg [info] ℹ 「wds」: 404s will fallback to /

2022-08-27T13:55:40.853 app[8499e70e] cdg [info] Starting the development server...

2022-08-27T13:56:57.566 app[8499e70e] cdg [info] [ 81.397878] Out of memory: Killed process 538 (node) total-vm:10932952kB, anon-rss:172352kB, file-rss:0kB, shmem-rss:0kB, UID:0 pgtables:5428kB oom_score_adj:0

2022-08-27T13:56:57.651 app[8499e70e] cdg [info] The build failed because the process exited too early. This probably means the system ran out of memory or someone called `kill -9` on the process.

2022-08-27T13:56:58.344 app[8499e70e] cdg [info] Starting clean up.

My fly.toml configuration

# fly.toml file generated for rotondo-website on 2022-08-27T15:48:09+02:00

app = "rotondo-website"
kill_signal = "SIGINT"
kill_timeout = 5
processes = []

[env]

[experimental]
  allowed_public_ports = []
  auto_rollback = true

[[services]]
  http_checks = []
  internal_port = 8080
  processes = ["app"]
  protocol = "tcp"
  script_checks = []
  [services.concurrency]
    hard_limit = 25
    soft_limit = 20
    type = "connections"

  [[services.ports]]
    force_https = true
    handlers = ["http"]
    port = 80

  [[services.ports]]
    handlers = ["tls", "http"]
    port = 443

  [[services.tcp_checks]]
    grace_period = "30s"
    interval = "15s"
    restart_limit = 2
    timeout = "2s"

My DockerFile

# pull official base image
FROM node:16-alpine3.12

# set working directory
WORKDIR /app

# add `/app/node_modules/.bin` to $PATH
ENV PATH /app/node_modules/.bin:$PATH

# install app dependencies
COPY package.json ./
COPY package-lock.json ./
RUN npm install

# add app
COPY . ./

EXPOSE 8080

# start app
CMD ["npm", "start"]

what am I doing wrong ?

I’ve also tried to upscale to the dedicate-cpu-8x with 64gb but I get the same error.

Thank you in advance