Unable to create secret

Hi there!

This is my first time deploying apps on Fly.io.
Currently, I’m in the process of deploying an app that I have been working for the past couple of weeks. However, I’m facing a blocker that I hope the community can help resolve.

I would like to add a DB connection string as an env var for my app.
Based on the documentation, secrets are the way to solve this issue.

However, whenever I try to set the secret locally from CLI, I get errors:

Here is the command I run

$ flyctl secrets set DATABASEURL="connection_uri"

The errors that I get:

Error Post "https://api.fly.io/graphql": unexpected EOF

Once, I got the following error message:

Error You ran into an error connecting to the Fly API. If the error persists, keep this request ID to help Fly Support track it down: 01G4JNFFCR7QQGZQ99W3BMNBFA-fra

Can somebody let me know what am I doing wrong and how to proceed?


I’m also getting errors when trying to create secrets.


I think they just fixed it. It’s working again.

1 Like

The API is having intermittent issues due to a consul outage: Fly.io Status - Deployment issues


Thanks for the update @michael !
As @pier said, the API is working again.

I was able to set the secret and deploy my app.
Thanks a lot for the help.