Turn off machines

I keep turning machines off but they seem to come back on after a few hours or so. the ‘vm’ section of my config looks like the following:

  cpu_kind = "shared"
  cpus = 1
  memory_mb = 1024
  processes = ["api"]

is there a way to stop them coming back online?

Hey @Darkimo , there’s a per service setting auto_start_machines that is set to true by default: Automatically stop and start Machines · Fly Docs
I think you can get the behaviour you’re looking for here by setting that to false for the relevant services in your config.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.