Tried everything for private networking... still stuck!


I currently have two Golang services that I’ve deployed successfully with Docker and I am wanting to “link” my API we’ll call some-api to my image processor called some-image_processor internally without using the public link. Currently I have removed the [[services]] block so that it uses internal networking.

So I set up the API to use http://some-image_processor.internal:3500/v1 to make requests to the image processor, but the API fails to make the request successfully. I feel like I’ve done what other threads have asked to help on but to no avail. Any help trying to figure it out would be great, thanks!

Hi @Mahcks

Are you sure that some-image_processor is listening on port 3500 internally?

What error(s) are you getting when you send requests to the image processor?

Thanks for the response!

I get (bound on host and port 3500) When starting up the image processor. This is the error I get when making a POST request: Post "http://some-image_processor.internal:3500/v1/cdn": dial tcp [ipv6_address_i_assume]:3500: connect: connection refused

Looks like you might be binding to IPv4 only, try binding to IPv6 using [::] instead of

Ahhh I had it set to [::] in the config but I use Fiber, so in the fiber.Config I had to set Network to tcp6 and that solved it. Thank you for getting my brain going!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.