Support for postgres 16 on

We just tried to migrate our postgres database from another hosting when we realized, our current database has version 16 whereas fly seems to support only up to postgres 15.3 (which is the default wehn creating a db cluster).
We assume postgres 16 is not yet available on fly, since this command failed:
fly pg create --image-ref flyio/postgres:16

  • Is it correct, that fly not yet supports version 16 or is the command above faulty?
  • Is there a way to list the available versions of postgres supports?
  • Is it at all desired users choose a non default version or has this drawbacks, since the documentation about postgres versions or images is very thin?

Thanks in advance!

Hi there, I haven’t worked much on Fly Postgres myself, but you can find available versions of the image used by fly pg create here: At time of writing, the latest available version is 15.6. The different versions of this image reflect changes to the Fly Postgres App as well as changes to Postgres itself.

If you wanted to use a non-default version, you could do fly pg create --image-ref flyio/postgres-flex:<version>, for example, where “version” is one of those available in the registry (note that it’s flyio/postgres-flex that you want, not flyio/postgres). I think we would generally recommend using the default, latest version of the Fly Postgres App to have its expected behavior; however, since this App is fully open source, you could fork it and modify it to meet your needs, for instance, to use a later version of Postgres. One drawback of this is that you wouldn’t be able to use fly postgres commands to administer your App. Another is that it would likely make it harder for us to provide help, although Fly Postgres is not managed postgres anyways.

I hope this info helps, and please feel free to write back with any further questions.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.