supercronic cannot install curl

I am trying to install supercronic in a rails app and I am stuck trying to install curl.
I have added this to my dockerfile:
RUN apt-get install -y curl
but I get this error:
E: Unable to locate package curl

Has anyone had this problem?


Hi, there

Have you tried running apt-get update before apt-get install?

apt-get update is run a few times in the dockerfile. I appended curl to the line which installs postgresql-client and it seems to have installed.
However now I get a different error from curl…
executor failed running [/bin/sh -c curl -fsSLO "$SUPERCRONIC_URL" && echo "${SUPERCRONIC_SHA1SUM} ${SUPERCRONIC}" | sha1sum -c - && chmod +x "$SUPERCRONIC" && mv "$SUPERCRONIC" "/usr/local/bin/${SUPERCRONIC}" && ln -s "/usr/local/bin/${SUPERCRONIC}" /usr/local/bin/supercronic]: exit code: 23

I’m assuming this is failing when you run fly deploy, right?
Have you tried building the container on your own machine? If so, did it work?

Yes, this is the output when I run docker build -t my_app_name locally

Since this is failing locally, I don’t think this is related to Fly’s platform, but correct me if I’m wrong or missing any details.

On a quick search, I found macos - Why does cURL return error "(23) Failed writing body"? - Stack Overflow, which looks a little like your case. I’d start there.

Ok so it looks like the filesystem of my container is read only. I ran a bash shell and I was not able to create a file.
My docker knowledge does not extend to knowing why this is the case but I appear to have solved the problem by moving the supercronic download and install to higher up in the dockerfile where the filesystem appears to be writable…

Thanks for the help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.