SSL config for ecto repo with fly hosted postgres


I read in multiple threads that if I use the fly hosted postgres and connect internally I do not need to worry about ssl between the deployment and postgres.

I am wondering then why do I see these logs:

 2023-02-08T09:17:38.000 app[59d19fb6] ord [info] 09:17:37.999 request_id=F0HOv1olevvRwI0AABWB [warning] Description: 'Server authenticity is not verified since certificate path validation is not enabled'

2023-02-08T09:17:38.000 app[59d19fb6] ord [info] Reason: 'The option {verify, verify_peer} and one of the options \'cacertfile\' or \'cacerts\' are required to enable this.' 

This is my repo config:

  priv: "priv/repo",
  url: "xxx?sslmode=disable",
  pool_size: 10,
  parameters: [
    tcp_keepalives_idle: "60",
    tcp_keepalives_interval: "5",
    tcp_keepalives_count: "3"
  socket_options: [:inet6, {:keepalive, true}]

I have 2 instances running in different regions that are connected with libcluster.
I see the logs from both (but not at the same time) around deployment.
I use GitHub - superfly/fly_rpc_elixir: Makes it easier to build distributed Elixir applications on the platform. Adds region awareness to an app and makes it easy to perform RPC calls in other regions.

Any ideas? It does not seem to happen always and it does not seem to affect functionality.