[solved] Changing secret env, still trouble changing hostname

Struggling to get to change the fly.dev url my {Ghost} app is running from.

All good deploying the app, it is running fine. It runs fine out of OLDDOMAIN

But then when trying to change the url the app would still only render out of the OLDDOMAIN, even though in the deploy logs I’d get “Your site is now available on NEWDOMAIN”. So, the ENV has been set, despite that, the url has not changed.

The hostname throughout all these trials under dashboard/overview kept unchanged as OLDDOMAIN.

  • I’ve tried setting a new secret ENV → no luck
  • I’ve tried unsetting and setting the secret ENV → no luck
  • I’ve tried explicitly setting a url ENV inside fly.toml → no luck

I’m about to redeploy it all (it is a new app) but wanted to report this issue to the team.

domain in domain.fly.dev is the name of your Fly app. I don’t think it is mutable, see: What happens when you remove a dedicated IP? - #2 by kurt. You can, however, deploy the same code to a new Fly app, and name it whatever you like (as long as the name is not taken by others).

I am not familiar with the Ghost blogging platform, so can’t say much what role env vars play here. May be @Curiositry does.

1 Like

I believe you are correct, @ignoramous.

In my tutorials, the part about setting the URL is telling Ghost to use the url appname.fly.dev for navigation links and such, not telling Fly to update the app name.

I haven’t tried changing the fly app name; I’m not sure if that’s possible. If it was, it would probably entail changing app = appname at the top of fly.toml, not changing url = https://appname.fly.dev in the [env] section.


“We don’t currently support renaming apps — the app name is integrated deeply into multiple systems, so it’s really difficult to propagate a name change through the entire stack.”

1 Like

Many thanks @Curiositry and @ignoramous . Understood. Appreciate the input.

1 Like