SFTP PUT doesn't find my local files

Hey there.

I’m trying to PUT some files on my fly volume.

when trying fly ssh sftp shell

and them put file.txt file.txt

I got this error open local file: open file.txt: no such file or directory

I also have tried to provide the full path and some variations, but got same error.

How do I know where my local base path is?

I’m assuming that the SFTP assumes some base directory as root. Is that my current working dir when I run the Fly ssh sftp? I tried the path assuming that didn’t work either.

Are you on the latest version of flyctl?

I just tried running fly ssh sftp shell in the same directory as my fly.toml file. I copied a folder in the directory with put test.txt test.txt and it transferred fine.

Maybe try prepending the command with “LOG_LEVEL=debug” to get some more logging?

1 Like

Hey Brian, just found my error here.

I was adding a dash before the dir name so intead os doing dir/file.txt
I was doing /dir/file.txt

I did that hundred times yesterday without noticing.

thanks for your help.