Running TCP DNS server?

A post was split to a new topic: DNS over TCP works, but UDP doesn’t

Was able to deploy over TCP/853. But no connections seems to reach it.

Also tried using fly-global-services as hostname, then even TCP/53 stops working with [error] Error 2000: problem connecting to app instance.

Not ready yet?

@thomas ^ we have open requests for 853 and 7777.

Hey! 853/tcp should work now (you don’t need fly-global-services for this! You only need that for UDP, so that our XDP code doesn’t mess with the UDP DNS that your VM already generates).

7777/tcp turns out to be slightly tricky for reasons I am too embarassed to report here but will explain once we’ve fixed it, which is the next thing on my docket.

Sorry for the delay on the first port; I added it to our API, but it was waiting on a fleet deploy to actually work. It is very silly that we have to do big deploys to add ports, and that too is something we are working on fixing.

3 Likes

Hi, 853/tcp is still not working. Tried a redeployment a few mins ago.

Unable to connect to it, getting Connection refused error.

Edit (3h later): It is working now! Thanks!

1 Like

Is this port 853 not available in all regions?

Port are mapped like so:

Services
PROTOCOL PORTS           
TCP      443 => 8080 []  
TCP      853 => 10000 []

I’m having trouble with deploying to all regions and with autoscaling:

Hi @Rowan_Hamilton , it should be, per https://community.fly.io/t/new-feature-every-public-port-now-allowed-for-tcp-services-this-means-http-too.

Can you check Troubleshooting your Deployment to see if your port-related config in the fly.toml is per this.

You can also look in the logs to see if you find anything that looks like an error, i.e., flyctl logs.