Request for Assistance with Auto-Start Machine Configuration on of mysql

Dear Fly Support Team,

I am writing to request your assistance with an issue I’m experiencing related to the auto-start functionality of machines in my deployment. Despite setting up the configuration as per the guidelines, the machines do not automatically start when new requests are received.

Application Name: chatgpt-plus-my-sql
Primary Region: sjc

Full Configuration Details:

  • Image Used: mysql:8

  • VM Specifications:

    • CPU Type: Performance
    • CPUs: 1
    • Memory: 2048 MB
  • Service Configuration:

    • Internal Port: 3306
    • Protocol: TCP
    • Auto-Stop Machines: True
    • Auto-Start Machines: True
    • Minimum Machines Running: 0
    • Processes: [‘app’]
  • Port Configuration:

    • Port: 3306
  • Process Configuration:

    • App Process Commands: --datadir /data/mysql --default-authentication-plugin mysql_native_password
  • Mount Configuration:

    • Source: “chatgpt_plus_mysql_data”
    • Destination: “/data”
  • Environment Variables:

    • MYSQL_DATABASE: “chatgpt_plus”
    • MYSQL_USER: “chatgpt_plus”
# fly.toml app configuration file generated for chatgpt-plus-my-sql on 2024-03-16T18:17:27-10:00
# See for information about how to use this file.

app = 'chatgpt-plus-my-sql'
primary_region = 'sjc'

  image = 'mysql:8'

  cpu_kind = "performance"
  cpus = 1
  memory_mb = 2048

  internal_port = 3306
  protocol = "tcp"
  auto_stop_machines = true
  auto_start_machines = true
  min_machines_running = 0
  processes = ['app']

  port = 3306

  app = """--datadir /data/mysql \
    --default-authentication-plugin mysql_native_password"""

  source = "chatgpt_plus_mysql_data"
  destination = "/data"

  MYSQL_DATABASE = "chatgpt_plus"
  MYSQL_USER = "chatgpt_plus"

Despite these settings, when all machines are stopped and a new request hits port 3306, the machines do not automatically start as expected. I have verified all configurations and there are no obvious errors in the logs that could explain this behavior.

Could you please provide insights or guidance on whether there might be an oversight in my configuration or additional steps needed to ensure that the auto-start functionality operates as intended?

I appreciate your help in resolving this issue and look forward to your prompt response.

Best regards,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.