Re deploy of mysql instance keeps crashing


I have a mysql instance that has been running for the past couple months. I just did a re deploy (changing a config variable: innodb-dedicated-server), and it failed.
I have since tried removing that config variable, but still can’t deploy.

I have tried all troubleshooting steps, nothing seems to get it unstuck. The error on deploy is below:

 2023-09-19 19:22:14+00:00 [ERROR] [Entrypoint]: mysqld failed while attempting to check config
  	command was: mysqld --default-authentication-plugin mysql_native_password --datadir /data/mysql --performance-schema=OFF --innodb-buffer-pool-size 64M --verbose --help --log-bin-index=/tmp/tmp.B5cnMorLjp
  Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.
  Thread pointer: 0x0
  Attempting backtrace. You can use the following information to find out
  terribly wrong...
  stack_bottom = 0 thread_stack 0x100000
  /usr/sbin/mysqld(my_print_stacktrace(unsigned char const*, unsigned long)+0x41) [0x2158f91]
  /usr/sbin/mysqld(print_fatal_signal(int)+0x397) [0xff5e87]
  /usr/sbin/mysqld(handle_fatal_signal+0xa5) [0xff5f45]
  /lib64/ [0x7f342248cd40]
  /usr/sbin/mysqld(Delegate::Delegate(unsigned int)+0xaf) [0x1de990f]
  /usr/sbin/mysqld(delegates_init()+0x34) [0x1de9c14]
  /usr/sbin/mysqld() [0xd73f6b]
  /usr/sbin/mysqld(mysqld_main(int, char**)+0x22ab) [0xd7ab1b]
  /lib64/ [0x7f3420a32e45]
  /usr/sbin/mysqld(_start+0x2e) [0xd5b0ae]
  The manual page at contains
  information that should help you find out what is causing the crash.

Hey there,

Would you mind providing your fly.toml file so we can get a better understanding of what’s going on?

Yup, here you go:

app = "app-db"
kill_signal = "SIGINT"
kill_timeout = 5


  MYSQL_DATABASE = "app_db"
  MYSQL_USER = "my_app_user"

  image = "mysql:8"

  cmd = [
	"--innodb-buffer-pool-size", "64M"

hi @xflysaround, if you can, please also confirm which version of Mysql you’re running.

  • Daniel

Since the database is down, I can’t get the exact version. I know it was 8.0x though.

I believe this is a known issue with the Oracle Linux-based mysql Docker image since v8.0.33. A workaround would be to downgrade to 8.0.32 or use the Debian-based image by changing your build.image from "mysql:8" to "mysql:8.0.32" or "mysql:8.0-debian" until the underlying issue is investigated further and fixed.

1 Like

That did the trick! Thank you soooo much!!!