Phoenix app: The app is not listening on the expected address

Running fly launch:

WARNING The app is not listening on the expected address and will not be reachable by fly-proxy.
You can fix this by configuring your app to listen on the following addresses:

So I tried adding this to prod.exs:

config :algora, TyndaleWeb.Endpoint,
  url: [host: "", port: 8080],
  cache_static_manifest: "priv/static/cache_manifest.json"

And there is no change.

Not sure what else I can do to have the app listen on 8080. Any ideas?


app = 'tyndale-app'
primary_region = 'lax'
kill_signal = 'SIGTERM'


  PHX_HOST = ''
  PORT = '8080'

  internal_port = 8080
  force_https = true
  auto_stop_machines = false
  auto_start_machines = true
  min_machines_running = 0
  processes = ['app']

    type = 'connections'
    hard_limit = 1000
    soft_limit = 1000

  memory = '4gb'
  cpu_kind = 'shared'
  cpus = 2

In the Endpoint config, you wanna have a look at the http option for the adapter config here: Phoenix.Endpoint — Phoenix v1.7.14

You want the adapter to serve HTTP requests on port 8080, the url config option is used for generating URL’s throughout the app.

Give these options a try (with your other options still there as well):

config :algora, TyndaleWeb.Endpoint,
  # to generate urls with `` as the host
  url: [host: "", port: 443],
  # To serve http requests on port 8080
  http: [
    port: 8080
    # or if this is in runtime.exs you can set it dynamically:
    port: String.to_integer(System.get_env("PORT", "8080"))