OOM issue even with swap ram added

That sounds simpler, thanks.

Do you know if it’s possible to also make flyctl use the system WireGuard tunnel instead of trying to create its own userspace WireGuard tunnel?

(I thought fly ssh console -A <app>.internal might work, at least for SSH; but it seems like it still tries to create a userspace WireGuard tunnel; and if I remove the agent’s WireGuard tunnel, fly ssh fails with “Error: tunnel unavailable: failed probing “personal”: context deadline exceeded”. This isn’t critical, because it’s possible to connect using the native SSH client thanks to fly ssh issue.)

1 Like

Good question! I never tried it myself on my local machine but I have a hunch! Try setting export FLY_REMOTE_BUILDER_HOST_WG=1 on your terminal and see if that helps.

We did that for Building an In-Browser IDE the Hard Way · Fly since you’d be on a Code Server machine and WireGuard is setup there so you have access to .internal domains.

Here’s the code for that in case you’re curious: flyctl/docker.go at 4377c6afe144b23b1260119dcd26285f5d094845 · superfly/flyctl · GitHub so there’s a chance this flag only works for remote builders.


I tried it out but it didn’t work. Looks like SSH uses a different code path (source). Oh well.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.