Must be amd64 architecture for linux os, found arm64 linux.

Hey Guys,

right now im facing this issue:
Searching for image ‘woudan/homework’ remotely…
Error failed to fetch an image or build from source: image must be amd64 architecture for linux os, found arm64 linux

When i execute => flyctl launch --image woudan/homework --now

but im pretty sure that my image should now be the correct architecture.
Is there any Cache or anything i have to clear beforehand?
I already did => fly version update
Oh and im using the Web CLI.

Thanks :slight_smile:

Here is the link to DockerHub Docker

Sounds similar to Docker deploy failing due to using wrong image?, which was supposed to have been fixed. Have you tried pushing a new tag and using it? (e.g. “woudan/homework:v2”)

This sounds like an image that get built on MacOS. If you’re building this with docker, you need to do something like:

docker build . --platform linux/amd64

Then push it to Docker Hub.

That actually worked thank you don’t know why because I already had a tag that was for amd64

Thanks i did it already that way and DockerHub showed it as amd64 but apparently it has something to do with it being not amd64 at the start

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.