mkdir broken on Docker remote builder using nix

This was working fine until recently, I’ve tried previous image tags, and it doesn’t work either.

This simple Dockerfile fails to build now:

FROM nixos/nix

RUN mkdir /app

I thought maybe /app had become protected by Fly or something, but any variant still fails:

FROM nixos/nix

RUN mkdir /blah

Some more notes: running this on a local Docker daemon works fine. Other images work fine:

FROM alpine

RUN mkdir /app

So it’s something specific to this image. I’ve also tried deleting the remote builder and using a new one, but that did not help.

Actual error:

 => ERROR [2/2] RUN mkdir /app                                                                                                        0.4s
 > [2/2] RUN mkdir /app:
Error failed to fetch an image or build from source: error building: executor failed running [/bin/sh -c mkdir /app]: exit code: 139

Any ideas what’s happening? Thanks for the help.

This is almost definitely the same problem: Segmentation fault no matter what i have in my Dockerfile

We’re rolling out updated kernels next week: Status - Host kernel upgrades

You can try deleting the remote builder and letting us create you a new one. It’s possible it will end up on a host with an updated kernel, but it’s not something you can control directly.

Thanks. I tried a few times but no luck, I guess I’ll wait till the July 19th release.

@kurt : confirming the just-completed maintenance seemed to fix this issue.

1 Like