I have created a new volume for an existing app but the volume will not attach to the machine

I have created a new volume for my api where i add the following to the fly.toml
app = “blogapi1200”
primary_region = “ewr”



internal_port = 3000
force_https = true
auto_stop_machines = true
auto_start_machines = true
min_machines_running = 0
processes = [“app”]

cpu_kind = “shared”
cpus = 1
memory_mb = 1024
when i run fly deploy i get the following error:
Process group ‘app’ needs volumes with name ‘myapp_data’ to fullfill mounts defined in fly.toml; Run fly volume create myapp_data -r REGION -n COUNT

which i have run and if i go to my dashboard the volume is there with the proper name but everytime i run fly deploy I get the same error and the volume will not attach

I deleted my app with fly destroy now and relaunched my app with the same name and the volume attached to the machine; but now none of my api routes are sending any response they just continually load with no response what so ever. Can I not delete an app then rename it with the same name? They all worked fine before I destroyed my app and redeployed it. Any ideas on what might be wrong?

Forgot to redeploy after adding my secrets

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.