I can't migrate PostgreSQL by flyctl ssh console -C "/rails/bin/rails db:migrate"

I have accessed PostgreSQL on Fly.io from Render.com, but I can’t migrate that because there is not found command ‘bundle’ and console says : “/rails/bin/rails: no such file or directory.”
How I fix this?

What does your Dockerfile look like?

actually I don’t have Dockerfile

The flyctl ssh console command in the title assumes a directory layout that both Rails 7.1 and fly io’s Dockerfile specify. If you are using a builder or buildpack, you would need to understand what directory layout they expect.

I would recommend creating and using a Dockerfile. To do so, remove the [build] section in your fly.toml, and run the following command:

bin/rails generate dockerfile

If this command detects the use of PostgreSQL, it will add the proper commands to run a migrate to your fly.toml for you: Fly Launch configuration (fly.toml) · Fly Docs

Following messages has returned:

Could not find generator ‘dockerfile’.
Run bin/rails generate --help for more options.

@minorex16 You probably need to install the dockerfile-rails gem before using the generator:

bundle add dockerfile-rails --optimistic --group development

After this you should be able to generate the Dockerfile as mentioned above:

bin/rails generate dockerfile

You can find more details about the generator in the GitHub repository.

1 Like


I’ve tried this command and deployed, but still got error.
What should I do?

That would entirely depend on what error you are seeing.

Start here: Existing Rails Apps · Fly Docs

If you tell us the error, we might be able to point you in the right direction.

The error is like this
fork/exec app/bin/rails: no such file or directory
Error: ssh shell: wait: remote command exited without exit status or exit signal

That message sounds like it came from fly ssh console, which means that your deploy (and probably migration) were already successful?

It looks like you are now trying flyctl ssh console -C "app/bin/rails..." instead of the command lin the title of this post: flyctl ssh console -C "/rails/bin/rails...". If you go back to using /rails instead of app, things should work better.

It still doesn’t work.

@minorex16 can you share your Dockerfile and Gemfile?


source "https://rubygems.org"
git_source(:github) { |repo| "https://github.com/#{repo}.git" }

ruby "3.1.4"

# Bundle edge Rails instead: gem "rails", github: "rails/rails", branch: "main"
gem "rails", "~> 7.0.7"

# The original asset pipeline for Rails [https://github.com/rails/sprockets-rails]
gem "sprockets-rails"

# Use sqlite3 as the database for Active Record
# gem "sqlite3", "~> 1.4"
gem 'sqlite3'

gem 'pg'

gem "dotenv-rails"

# Use the Puma web server [https://github.com/puma/puma]
gem "puma", "~> 5.0"

# Use JavaScript with ESM import maps [https://github.com/rails/importmap-rails]
gem "importmap-rails"

# Hotwire's SPA-like page accelerator [https://turbo.hotwired.dev]
gem "turbo-rails"

# Hotwire's modest JavaScript framework [https://stimulus.hotwired.dev]
gem "stimulus-rails"

# Build JSON APIs with ease [https://github.com/rails/jbuilder]
gem "jbuilder"

# Use Redis adapter to run Action Cable in production
gem "redis", "~> 4.0"
gem 'redis-rails'

# Use Kredis to get higher-level data types in Redis [https://github.com/rails/kredis]
# gem "kredis"

# Use Active Model has_secure_password [https://guides.rubyonrails.org/active_model_basics.html#securepassword]
# gem "bcrypt", "~> 3.1.7"

# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
gem "tzinfo-data", platforms: %i[ mingw mswin x64_mingw jruby ]

# Reduces boot times through caching; required in config/boot.rb
gem "bootsnap", require: false

# Use Sass to process CSS
# gem "sassc-rails"

# Use Active Storage variants [https://guides.rubyonrails.org/active_storage_overview.html#transforming-images]
# gem "image_processing", "~> 1.2"

group :development, :test do
  # See https://guides.rubyonrails.org/debugging_rails_applications.html#debugging-with-the-debug-gem
  gem "debug", platforms: %i[ mri mingw x64_mingw ]

group :development do
  # Use console on exceptions pages [https://github.com/rails/web-console]
  gem "web-console"

  # Add speed badges [https://github.com/MiniProfiler/rack-mini-profiler]
  # gem "rack-mini-profiler"

  # Speed up commands on slow machines / big apps [https://github.com/rails/spring]
  # gem "spring"

group :test do
  # Use system testing [https://guides.rubyonrails.org/testing.html#system-testing]
  gem "capybara"
  gem "selenium-webdriver"
  gem "webdrivers", "~> 5.3.0"

gem 'devise'
gem 'actioncable'
gem "bootstrap", "~> 5.2"

gem "refile", require: "refile/rails", github: 'manfe/refile'
gem "refile-mini_magick"

gem 'net-http'

gem "ruby-openai"

gem 'aws-sdk-rails'
gem 'aws-sdk-s3', '~> 1'

gem 'googleauth'

gem 'omniauth-rails_csrf_protection'
gem 'omniauth-github'
gem 'omniauth-google-oauth2'

gem "dockerfile-rails", ">= 1.6", :group => :development


# syntax = docker/dockerfile:1

# Make sure RUBY_VERSION matches the Ruby version in .ruby-version and Gemfile
FROM ruby:$RUBY_VERSION-slim as base

# Rails app lives here
WORKDIR /rails

# Set production environment
    BUNDLE_PATH="/usr/local/bundle" \
    BUNDLE_WITHOUT="development:test" \

# Update gems and bundler
RUN gem update --system --no-document && \
    gem install -N bundler

# Install packages needed to install nodejs
RUN apt-get update -qq && \
    apt-get install --no-install-recommends -y curl && \
    rm -rf /var/lib/apt/lists /var/cache/apt/archives

# Install Node.js
ENV PATH=/usr/local/node/bin:$PATH
RUN curl -sL https://github.com/nodenv/node-build/archive/master.tar.gz | tar xz -C /tmp/ && \
    /tmp/node-build-master/bin/node-build "${NODE_VERSION}" /usr/local/node && \
    rm -rf /tmp/node-build-master

# Throw-away build stage to reduce size of final image
FROM base as build

# Install packages needed to build gems
RUN apt-get update -qq && \
    apt-get install --no-install-recommends -y build-essential git libpq-dev pkg-config

# Build options
ENV PATH="/usr/local/node/bin:$PATH"

# Install application gems
COPY --link Gemfile Gemfile.lock ./
RUN bundle install && \
    bundle exec bootsnap precompile --gemfile && \
    rm -rf ~/.bundle/ "${BUNDLE_PATH}"/ruby/*/cache "${BUNDLE_PATH}"/ruby/*/bundler/gems/*/.git

# Copy application code
COPY --link . .

# Precompile bootsnap code for faster boot times
RUN bundle exec bootsnap precompile app/ lib/

# Precompiling assets for production without requiring secret RAILS_MASTER_KEY
RUN SECRET_KEY_BASE=DUMMY ./bin/rails assets:precompile

# Final stage for app image
FROM base

# Install packages needed for deployment
RUN apt-get update -qq && \
    apt-get install --no-install-recommends -y curl imagemagick libsqlite3-0 postgresql-client && \
    rm -rf /var/lib/apt/lists /var/cache/apt/archives

# Copy built artifacts: gems, application
COPY --from=build "${BUNDLE_PATH}" "${BUNDLE_PATH}"
COPY --from=build /rails /rails

# Run and own only the runtime files as a non-root user for security
RUN groupadd --system --gid 1000 rails && \
    useradd rails --uid 1000 --gid 1000 --create-home --shell /bin/bash && \
    chown -R 1000:1000 db log storage tmp
USER 1000:1000

# Deployment options

# Entrypoint prepares the database.
ENTRYPOINT ["/rails/bin/docker-entrypoint"]

# Start the server by default, this can be overwritten at runtime
CMD ["./bin/rails", "server"]

Dockerfile and Gemfile look good.

When you say it still doesn’t work. What is it (i.e., what command are you trying?), and what is the response you see?

I changed command to fly ssh -C “rails/bin/rails db:migrate”, but I got same error: no such file or directory.

Try the command specified in the title of this post:

flyctl ssh console -C “/rails/bin/rails db:migrate”

Note the slash after the first quote.

returned: fork/exec /rails/bin/rails: no such file or directory

Do you have a bin/rails file in your source? Your Gemfile suggests Rails 7.0.7, so that file should be there.

If not, the following command will generate one:

rake app:update:bin

Here’s what I get when I run that command:

% rake app:update:bin
       exist  bin
   identical  bin/rails
   identical  bin/rake
   identical  bin/setup

If you get something different, rerun fly deploy and try again.

I’ve got the same response.