I can't launch my first app

I’m trying to launch my first app but when I do flyctl launch and follow the prompts I get the following.

I then visit the link stated and tried to Add Credit Card and I get redirected to the Apps page, I tried to click the Buy Credit and it was the same result.

You get redirected to the apps page after entering your credit card information or before?

I just tried and was redirected to the payment page. Though I haven’t tried going through with it.

I didn’t get redirected to the credit card information page at all, it just went straight to the apps page.

Here is a screen recording of this

I’m experiencing the same.

Same.

No live support, only email or forum.
A lot of bugs in the web side - missing notification messages, sign out is not working, payments is not working, wrong texts in forms, …
Not ready for production.

Please keep the thread positive. I’m sure the team are busy getting the product to a good production state, but there are always bug in products. I mean Gmail was beta for so many years before they decided it was production ready.

1 Like

:smiley: ok, is this product in WIP state? Then I will keep my messages positive.

1 Like

We’re troubleshooting problems with billing. We haven’t been able to replicate yet, but it’s preventing people from signing up.

1 Like

Thanks for the update. Let me know if there is any information I can provide that could potentially help.

OS: Windows
Terminal: Powershell
Browser: Firefox

This should be fixed soon, we reverted to a previous version of our UI app. It required a DNS change, though, so your browser may have previous IPs cached. Please give it another try.

Fix is out! Please let us know if you run into any more issues.

The core problem here is we broke our Stripe integration. We put a new proxy in front of our UI, it wasn’t sending the host header through properly. So the links coming back from the UI were a different domain you probably didn’t have a cookie for. When you visit one of the “add card” URLs it auths you and then redirects you to stripe. But with no cookie, it couldn’t auth.

We rolled back the proxy change for now.

Add credit card - opens Stripe form. Looks good.

Buy credits → Buy - opens blank page with text “not found”

It’s working now. Thanks for this.

@dukalskis we’re looking into it. you didn’t get billed this time, but if there was an issue we’ll sort it out for you

1 Like

Working for me now. Thanks for the quick turn around.

What URL does that blank page have?

For personal its working, for organization not

I changed my org name to my_org, this info is not for public.

https://web.fly.io/organizations/my_org/prepay_checkout?amount=2500&return_url=https%3A%2F%2Ffly.io%2Forganizations%2Fmy_org

This is vaguely related, but it’s happening because your cookies are in a weird state. If you delete your fly.io cookies, then login again, you should be good to go.

I deleted fly.io cookies. No changes, cant buy credits (blank page)