HTTP checks are not using proxy_protocol when enabled


HTTP checks seem to be sending requests without the PROXY protocol, that is all fine, but I believe they should be doing so when the option is enabled in your fly.toml.

Otherwise you will have external traffic using the proxy protocol, and internal http checks that don’t have it (on the same interface).

The workaround is having a different listener with proxy protocol enabled pointing to an internal service with the protocol disabled, so that external traffic errors out and the internal http checks can do their job.

Thank you for what is setting up to be a fantastic platform so far!

1 Like

I’m also facing this problem. There should be an http_healthchecks option to enable sending proxy protocol requests.

Ahhh this is a good point. We can’t make this work, unfortunately. Right now we rely on Consul to do health checking.

The best bet is to listen on a second port that doesn’t expect proxy proto, then set the port = <newport> in the health check definition.