How to fix postgres on pending state?

I have an application database that is on “pending” for a couple of hours already.
I tried to restart, scale up and down, update the image version - and nothing happens.
The state keeps as pending. Logs tab is freezed (shows just “waiting for logs”).

I created a second postgres database on the same region (GRU) and everything is working properly.
How do I recover this database?

I was even wondering that I can attach the volume from the old one to the new instance. Is this possible? If so, someone could guide me on how to do this?

1 Like

Tulio, sadly we are still in the same situation.

Here’s how I created a new postgres database from the old one:

  1. Get the volume id: fly volumes list -a your-db-name

  2. Get the (latest) snapshot ID for that volume: fly volumes snapshots list volume_id

  3. fly postgres create --snapshot-id snapshot_id

Hope it helps while we wait an answer from Fly.


Just joining the chorus here: I’m having the same problem, more than 24 hours ago my database stopped for no apparent reason and it doesn’t come back either with rescale or vm change. No logs, no change in status, just “pending”

Just did what @fermuch said. It worked like a charm. Ty!

Glad it works! Sad no response from Fly yet…

Looks like there were some issues going on with a particular host. If you are still having issues, please let me know!

@shaun what about my host and @tuliofaria 's host? Were those affected too?

If you were deploying into region gru it’s likely you were hitting the same borked host. If you were deploying into a different region and are experiencing issues, let me know.