Health Checks Failing with "failed to get VM"

I recently renamed my main web process from “web” to “app”, because this seemed to be what fly was recommending by default.

However, since I’ve done that, I can’t get health checks to pass. They are failing with the following error:

Error: error while watching health checks: All attempts fail:
#1: failed to get VM 9185929c964e08: Get "": net/http: request canceled
#2: context deadline exceeded

When I look at the logs on the VM everything looks fine, and it seems to be an issue accessing the machine itself? Also I am using Apps v2, so am not sure about the “v1” in the URL or if that’s maybe related.

I have tried cloning the machine and get the same result.

This was I think caused by a duplicate service declaration. I had similar sections in both [http_service] and [[services]]. Once I moved everything (including the health check) over to [http_service] it seems to be working again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.