gunicorn: command not found for Go deployment

I am trying to deploy my go application to and i am running into some issues. When doing fly launch I entered all the details it asked me for, including adding a redis database. All of the fly launch steps went well, but when I ran fly deploy, I get this error:

bash: gunicorn: command not found

in the console. From what I understand, gunicorn is only needed for python deployments so I’m not sure why it’s running for my go app. Here is my fly.toml file:

# fly.toml app configuration file generated for triton-search on 2023-07-04T14:15:55-07:00
# See for information about how to use this file.

app = "triton-search"
primary_region = ""

  builder = "paketobuildpacks/builder:base"
  buildpacks = [""]

  PORT = "8080"

  command = "go run main.go"

  internal_port = 8080
  force_https = true
  auto_stop_machines = true
  auto_start_machines = true
  min_machines_running = 0

Would appreciate any help / guidance in fixing this issue.

Nevermind, I created a new folder, copied my code over, and launched a new instance and it worked. Not sure what was wrong initially.

1 Like