getting cached assets even though `statics` is disable on my `toml` file


up until yesterday, I was using [[statics]] entry on my config file to get my assets cached. right now, I’m playing around with Cloudflare and I wanted to use their edge caching so I set up caching on their side and commented out the statics block on my toml config file, which I assume should stop caching them on fly’s side but something else is going on: fly-cache-status header says HIT, cf-cache-status says EXPIRED and the cache-control header value is public, max-age=0, must-revalidate
I believe at some point, somewhere fly is setting max-age to zero and forcing cloudflare to always see this file as stale/expired.
I managed to fix it by creating a caching rule for css/js files and overwriting the cache control header but I don’t think it is the best solution.