Fully clear deploy metadata docker ARG cache?

Even with fly deploy --no-cache, Changing the default value of a Dockerfile ARG value is not picked up.

For example

FROM phpswoole/swoole:php${PHP_VERSION}-alpine

If I previously built this image and I want to then change the default to ARG PHP_VERSION=8.2, fly still loads the old image: [internal] load metadata for docker.io/phpswoole/swoole:php8.1-alpine

Unless, I explicitly specify the build arg, e.g. fly deploy --no-cache --build-arg PHP_VERSION=8.2

Is there any way to fully flush the remote build cache one time so it I don’t need to provide the build-arg option forever?


Never mind :slight_smile:

I had this in my fly.toml and that’s why it wasn’t changing.

    NODE_VERSION = "14"
    PHP_VERSION = "8.1"