flyctl launch intermittently failing to make graphql requests

We’re using flyctl launch to launch one app with one machine, and we’ve tried doing this across a few regions (cdg, lax, lhr) - we’re seeing sporadic failures, with the same error each time:

==> Building image
Searching for image '<redacted>' remotely...
image found: <redacted>

Watch your deployment at<redacted>/monitoring

Provisioning ips for <redacted>
  Dedicated ipv6: <redacted>
  Shared ipv4: <redacted>
  Add a dedicated ipv4 with: fly ips allocate-v4

Error: Post "": read tcp> read: connection reset by peer

The same exact flyctl launch command sometimes fails and sometimes works. Does anyone have any ideas?

1 Like

We have investigated further and are seeing intermittent connection reset errors specifically from the MachinesCreateRelease GraphQL query (which we got from watching flyctl launch with LOG_LEVEL=debug).

When POSTing MachinesCreateRelease GraphQL requests directly to we see about 1 in 20 requests go through fine, but most return a socket closed by remote peer.

Do you have the same issue when you run fly deploy on an existing app? Also, can you run fly version and let me know which version you’re running?

Fortunately, things resolved later on the same day with no changes from our end.
flyctl version gives
flyctl v0.2.42 linux/amd64 Commit: 44aedf5b21a71b0c086d4603d2522f71e2908c61 BuildDate: 2024-04-24T22:03:44Z

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.