flyctl launch cmd didnt detect Dockerfile

Hello, I have a Issue when I try to use docker and flyctl the first time on MacOs, when I run flyctl launch command it detect a NodeJS app and not a Dockerfile app even though i have a Dockerfile in the root of my project, Docker is installed and i was able to build Image locally on Docker desktop so I dont get what’s the issue or what am I doing wrong or missing? it also worked fine on windows.


Scanners run in this order, so we check for a JS (node/bun) app before we check for a Dockerfile app.

When a Node.js application is detected, the scanner should prompt you as to whether you want to replace the Dockerfile or not, and before you make your choice you can even view a diff of the changes.

Ok I see, so I continu and run fly deploy, I didn’t see any prompt asking if i want to replace the Dockerfile or not nor either choice to make, and before running fly deploy cmd the only prompt I get was asking if i want to copy the fly.toml config to the new app, however I can see it build the app from Dockerfile, but I see a 3rd “Remote builder fly-builder-long-dream-7312 ready”, for unknown reason and it failed i am not sure… I am just confused since on windows I can see the terminal show the Dockerfileapp is detected unlike on the macOs that’s why i am asking.

Btw I see this message at the end is there something wrong ? I check the repo it looks like it updated succesfully but it also create a 3rd build “fly-builder-long-dream-7312” unfinished but I am not sure about it

Updating existing machines in ‘my-app name’ with rolling strategy
[1/1] Updating 4d8966dae66578 [app]
Error: failed to update VM 4d8966dae66578: parse to root/auth token: parse flyv1 token: invalid token prefix ‘Bearer fo1’

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.