Fly-log-shipper not sending logs to provider

I deployed an instance of fly-log-shipper by following the instructions:

  1. Created a new file folder directory
  2. Inside the folder, ran this:
    flyctl launch --image --name="loggy" --region=sea
  3. Updated internal_port in my local fly.toml to 8686
  4. Set my Logflare secrets like so:
  5. Set my ORG with flyctl secrets set -a loggy ORG=personal
  6. Ran flyctl deploy

It deploys successfully, and I have verified that it sees the logs from my other app by following these steps:

  1. flyctl ssh console -a loggy
  2. vector tap
  3. Do some actions in my other app, which generate logs – I can see these logs in the terminal where I ran the above two commands.

HOWEVER these logs are not showing up in any 3rd party provider I’ve tried to connect my fly-log-shipper app to. I’ve tried Honeycomb, Logflare, and Axiom by setting the values listed in the instructions with my own values from the respective platform, but nothing seems to be making it through.

I have tried their method to test sending a log event via curl, which does work. Is there anything I can do to debug from the side?

Redepoyed after seeing this and now it works just fine! I think my issue must have been similar.

1 Like