fly-log-shipper fails on LogTail: Authorization Violation

Is fly-log-shipper still compatible with LogTail?

I tried adding a new Vector source from LogTail:

I set my secrets on Fly:

But when I deploy, I get these failures:

2022-08-11T18:56:50.155 app[92b2cf05] ewr [info] 2022-08-11T18:56:50.155122Z INFO vector::app: Log level is enabled. level="vector=info,codec=info,vrl=info,file_source=info,tower_limit=trace,rdkafka=info,buffers=info,kube=info"
2022-08-11T18:56:50.160 app[92b2cf05] ewr [info] 2022-08-11T18:56:50.160028Z INFO vector::app: Loading configs. paths=["/etc/vector/vector.toml"]
2022-08-11T18:56:52.490 app[92b2cf05] ewr [info] 2022-08-11T18:56:52.490273Z ERROR vector::topology: Configuration error. error=Source "nats": NATS Connect Error: unexpected line while connecting: Err("Authorization Violation") 

I tried debugging with fly ssh console, but it can’t connect for some reason. Even if I manually add apt install openssh-server to the Dockerfile, the fly CLI can’t seem to form an SSH session.

I solved this by generating a fresh Fly.io access token for the server. I’m not sure why the previous access token wasn’t working, as I generated it from the command line with fly auth token from the same shell where I was deploying new versions to Fly.

It would be good if the error message could point the user to the ACCESS_TOKEN environment variable. I thought it was an auth issue with LogTail.

@tinypilot
How did you generate a fresh access token? I am getting this same error, and think it has something to do with my token. I am retrieving my token with the fly auth token command as well.